[time-nuts] Rapco 1804M - serial problems?

David J Taylor david-taylor at blueyonder.co.uk
Sun Oct 16 16:34:06 UTC 2011

I've just got a Rapco 1804M and while it works, within the limits of my 
antenna placement, the RS-232 serial out doesn't read very well, and seems 
to have incorrect characters.  The voltage levels look OK, and the 
terminal emulation program is set to 4800 baud, 8-bit, no parity, one stop 
bit, no flow control.  I've tried other combinations.  As near as I can 
measure, the baud rate is 4800.

Here's some sample output:

UTC Time  : 16:65:19 16/10?1q
UTC Time  : 16:25:20 16/10/11

Position  : 53 54.406 N  002 12.075 W  0239 M
PDOP      : 02
Sat PRN   : 28,19,32,01,11<22
Sat levål : 00,12,13,06,05,03
Fix, Mode : 2D , Coarse

UTC Time  : 16:25:21 16/10/11
UTC Time  : 16:25:22 16/10/11
UTC Time  : 16:25:23 16/10?11
UTC Time  : 16:25:24 16/10/11=
                              UTC Ti}e  : 16:25:25 16/10?11
UTC Time  : 16:25:26 16/10?11

The same serial port works correctly with 9600 baud Garmin signal, and I 
don't have any other available computers with spare RS-232 ports I can 
test against.

Am I missing the obvious, or is there something wrong with the serial 
port?  I do appreciate that the serial port isn't critical to the correct 
operation of the 1804M, but this has cast doubts about this particular 
unit into my mind!

David GM8ARV
SatSignal software - quality software written to your requirements
Web:  http://www.satsignal.eu
Email:  david-taylor at blueyonder.co.uk 

More information about the time-nuts mailing list