[time-nuts] Fwd: FE-5680A Physics package

Peter Bell bell.peter at gmail.com
Mon Oct 31 06:00:20 UTC 2011

Following up on my own post - it seems it is the Rb cell that's the
problem - I swapped the cell over (it's just held in place by hot
glue) and fault moved with the one from the bad unit. After removing
the heat-shrink, there are two separate glass cells in the assembly,
as I suspected.  The smaller one (on the left in the photo) was the
one closest to the lamp and if it contains anything at all, it's not
visible.  The second, slightly larger, cell seems to be the actual
absorption element and contains a small quantity of some silvery metal
(I.E. Rb)  partly in the pinch and partly deposited on the glass.

It all looks so simple it's hard to see what the problem could be -
the only thing I can think of is that the first cell has leaked (the
second one obviously hasn't, since the Rb is not oxidized).  The other
conclusion that I've reached from this is that these units are pretty
non-critical - as long as I used the good Rb cell assembly, it would
lock with any combination of housing / heater / photocell, RF
multiplier assembly and C-field coil / shield.  Ah well - put it to
one side until / if I get another dead unit, I guess.


On Sun, Oct 30, 2011 at 3:31 AM, paul swed <paulswedb at gmail.com> wrote:
> My comments have been about other rb cels and the fact that components in
> the rf oscillator tend to die and are generally replaceable. Additionally
> using the practice of heating the emission cell with heat gun to
> re-evaporate the accumulated rb seems to really revive a cel. So if its
> dead what the heck have some fun. I wrote up my info and its on Diddiers
> and Stanleys sites. Others like Magnu's and Stanley have written up their
> tricks.
> So good luck.
> Regards
> Paul.
> On Sat, Oct 29, 2011 at 12:54 PM, Peter Bell <bell.peter at gmail.com> wrote:
>> I was wondering if anyone on the list has ever had a play with these
>> things?  I had a couple of dead ones, and have managed to get the
>> first one working (easy fix - the 3.3V regulator was dead), but the
>> second seems to be a lot more troublesome.
>> Basically, everything seems to be working, but there is no resonance
>> dip detected at the photocell - however all the individual parts seem
>> to be OK.  I did a couple of quick and dirty tests firstly by swapping
>> the entire Rb cell assembly over between the two units - and the fault
>> swapped over with the Rb cell.  Both cells are running at the same
>> temperature, the photcells are good, and the working one still works
>> (on both main boards) even when you swap the snap diode / filter
>> assembly or the shield / c-field coil from the bad one.
>> Basically, all that's left is the photocell (which seems to pick up
>> light OK), the FET / Thermistor (unlikely, since the heater works
>> correctly), the lens (looks perfect) and the Rb cell itself.  So I'm
>> tending towards the "bad Rb cell" idea - but the problem is that I've
>> fixed quite a few Rb oscillators in the past (mostly Efratom FRKs and
>> a few FRSes) and I've never seen a bad Rb cell.  So I was wondering if
>> anyone else on this list thought it seemed likely.
>> (resent with the photo reduced in size).
>> Incidentally, when I was looking at the Rb cell, I noticed that it
>> seemed to be a pair of cells held together in a heat-shrink tube - I
>> assume that the first (slightly smaller) one is a isotopic filter and
>> the second is the actual absorption cell?
>> And does anyone have any schematics for these things?  FEI seem to
>> have the standard "send it back to us" approach that is increasingly
>> common recently - another reason I liked the FRSes.
>> _______________________________________________
>> time-nuts mailing list -- time-nuts at febo.com
>> To unsubscribe, go to
>> https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
>> and follow the instructions there.
> _______________________________________________
> time-nuts mailing list -- time-nuts at febo.com
> To unsubscribe, go to https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
> and follow the instructions there.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: FE-5680A Rb Cells.jpg
Type: image/jpeg
Size: 39627 bytes
Desc: not available
URL: <http://www.febo.com/pipermail/time-nuts/attachments/20111031/d189ff2d/attachment-0001.jpg>

More information about the time-nuts mailing list