[time-nuts] Sure Electronics GPS card, Linux quirk

Hal Murray hmurray at megapathdsl.net
Sun Feb 5 04:47:44 UTC 2012

I'm in the habit of using things like:
  cat /dev/ttyUSB0
when checking out GPS that I expect to send ASCII.

When I tried that with my new toy, it went bonkers.  In particular, the 
firmware LED went on, and the NMEA LED switched from blinking to solid on.  
The data included the stuff I expected, but it also included a lot of garbage.

I (finally) tracked that down to "echo" being set on the tty parameters.  
That echos a copy of each input character back to where it came from.  The 
cure is as simple as:
  stty -F /dev/ttyUSB0 -echo

Of course, there are other ways to get in trouble with tty parameters.  Here 
is the line I have stashed away in my notes on how to set things up:
  stty -F /dev/ttyxxx 9600 igncr clocal -echo -ixon

Now that I've got that sorted out, it responds to the $PTMKxxx commands.  
(I've only tried one.)

The Sure card uses the ST CP2102 USB to serial chip.  It's not very common, 
but there is a Linux driver for it.  I assume the default bits somewhere in 
the driver are different from defaults in the FTDI FT23x and the Prolific 
PL230x chips that are quite common.  I haven't looked at the source code.

In my quest for a low cost, no-soldering GPS gizmo that works well with NTP, 
I tried a Transystem GM-2.  It had the same sort of garbage.  That was a 
while ago.  I gave up and put it on the back burner.  Guess what.  It uses 
the same USB-serial chip.  It's working now.

These are my opinions, not necessarily my employer's.  I hate spam.

More information about the time-nuts mailing list