[time-nuts] Trimble Acutime Gold PPS

Miguel Barbosa Gonçalves m at mbg.pt
Sun May 19 17:03:16 EDT 2013


I am struggling trying to convert my Acutime's PPS signal from RS422 to
RS232 for NTP use.

I am using this converter: http://www.dpieshop.com/quatech
-sscvt500n-rs232-to-rs422485-serial-converter-p-282.html and I connected

- Port A (T+) to R+ on the converter
- Port A (T-) to R- on the converter
- PPS+ to T+ on the converter
- PPS- to T- on the converter

On the RS232 part of the converter

- TXD (pin 3) to computer pin 1 (DCD)
- RXD (pin 2)to computer pin 2 (RXD)
- GND (pin 5)to computer pin 5 (GND)

all other pins are connected to the same pin on the computer except for the
DCD on the converter which is not connected.

I can see the serial time code on the computer yet the PPS (a long 400 ms
one) doesn't seem to reach the computer.

I've tried everything I could remember off and connecting the RS422 PPS+
pin directly to the computer makes the NTP daemon stop randomly and losing
the PPS signal. I really think I need to convert the PPS signal (30 meters
long cable). Without PPS and using this converter NTP works fine. The
problem is the jitter I am getting.

I think I've exhausted every option with this converter and found this
converter: http://www.ko4bb.com/~bruce/GPS_RS232_RS422_Transceiver.html.

I might try it. Anyone here tried it or has any input for this situation??

I also think that from a time nut perspective building my converter instead
of using a black box will enable me to see what is the delay in the signal

Any help would be highly appreciated.

Kind regards,

More information about the time-nuts mailing list