[time-nuts] HP 59309A Clock runs, sets via GPIB, but no GPIB output?

Tom Van Baak tvb at LeapSecond.com
Fri Oct 7 20:15:19 EDT 2016

Hi Bob,

Yes, the hp 59309A is a wonderful little LED clock. I just re-tested the program I wrote to read/write the time and it still works.

For others that are wondering, the code is at http://leapsecond.com/tools/hp59309.c and a Win32 exe is there too.

Anyway, one possible suggestion is for you to use ++read 10 instead of just ++read. The 59309A is an early byte-oriented HP-IB device and the Prologix command set is more meant for line oriented communication (using CR or LF or EOI for termination). So when I use ++read10 everything is fine, but ++read, or ++read9 or ++read11 or ++read anything else will cause the Prologix to go into an infinite loop.

One other idea that may shed light on your problem is to use the /d (debug) option and have a look at the exact communication between the program and the Prologix and the 59309A. Then do the same with your Python code to see if it matches, down to the byte. Again, these vintage HP-IB instruments are wonderfully simple but they don't always take well to things we take for granted these days like extraneous line terminators or spaces or open-ended reads and such. If you really want some fun, use a GPIB bus analyzer.

Attached is the debug log from my 59309A.

If all else fails I can send you a known working 59309A so you can tell if the problem is with your PC, your Python tool, your Prologix, or your 59309A.


----- Original Message ----- 
From: "Bob" <bob at marinelli.org>
To: "TimeNuts" <time-nuts at febo.com>
Sent: Thursday, October 06, 2016 12:56 PM
Subject: [time-nuts] HP 59309A Clock runs, sets via GPIB, but no GPIB output?

I'd like to ask the HP 59309A owners on time-nuts if the following symptoms sound familiar, and if so, what would the fix be?

o New-to-me HP 59309A clock.
o Late build, 1985 date code on many parts.
o I replaced the big 1900 uF electrolytic before plugging it in.
o Visual inspection very clean, no corrosion, no battery.
o 12v reads 13.1v, 5v reads 5.3v, -2v reads -2.9v.
o Front panel switches and buttons all work as expected.
o Internal and external osc. both work as expected.
o Internal "format" switch set to 0000 i.e. comma, cal, no space.
o GPIB works to *set* the time, using Prologix Ethernet adapter.
o Prologix Ethernet adapter attached directly to the clock, no cables.
o Python code to set via GPIB attached below.
o Setting time via GPIB always works, tried many times.
o Reading time has never worked.  All I get is lots of ASCII 44444444444444444444444...
o Reading with Prologix ++read command
o Switches set to 1100010 i.e. Listen, ADDR 2 for normal operation
o Tried switches as 0000010 i.e. Talk Only, also resulted in continuous 4444444444444444444...
o Tried very long delays between every GPIB command, no change.
o Tried removing top cover and running a fan to bring entire clock to 21C, no change.
o Tried gently reseating the four boards and three socketed PROMS, no change.

Thanks to TVB for hp59309.c sample Windows Prologix USB code.  I based the Python Ethernet code on TVB, to read from the clock he sends command C and then ++read.  When I do that all I get are a zillion 0x34 '4' characters.

Seems strange that all the GPIB commands work.  I tried R reset, P pause T resume D day H hour M minute S second manually and they all work just fine.  I have never been able to read anything reasonable though.

As to the Prologix Ethernet adapter, I believe it is working OK electrically as I have been using it for weeks at a time reading PPS time intervals from a trusty HP 5334B counter, the adapter has read hundreds of thousands times from the 5334B.

Is there a trick to using the Prologix to read from the 59309A?

I did notice that the 59309A has at least one trick - in TVB's code where he reads the Prologix settings and only writes them if they need to be changed, that is actually required(!).  Just writing them every time seems to put the adapter into a strange state.

Page 4-2 of the 59309A manual seems to imply that the "Output State Machine" generates the GPIB output messages, using input from the "Data Memory".  AFAICT, those two functional blocks are the only ones that are not working for me.

I think A4U18 ROM is OK as it handles GPIB command decoding and R P T D H M S commands all work.

A5U15 appears to do the ASCII encoding for SP, CR, LF, ", : so it may or may not be OK.

A5U2 is described as "STATE MACHINE ROM (A5U2). This 4K ROM controls the operation of the circuits that develop the talk output of the 59309A."  Has anyone experienced failure of this ROM, and do the symptoms match what I'm seeing?

This is a lovely clock, and while I can't actually think of a reason to *need* the GPIB time output, I'd still like to fix it.


Bob Marinelli

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 59309-log.txt
URL: <http://www.febo.com/pipermail/time-nuts/attachments/20161007/8885716d/attachment.txt>

More information about the time-nuts mailing list