[time-nuts] Trimble UCCM weird behaviour

Attila Kinali attila at kinali.ch
Wed Nov 1 08:20:25 EDT 2017


I recently bought a Trimble UCCM from ebay and it shows a rather strange
behaviour. Beside the unit having a low sensitivity (the LEA-5 I have
considers satellites having a good C/N0 where the trimble cannot even
track them) it does not seem to properly lock. Periodically it steers
the DAC output to 0, then about half a minute later full down to the
negative maximum, another 15s later full up to the positive maximum.
It cycles this way for 2 to 6 times before settling again to "normal"
behaviour. As you can see from the first picture, the PPS offset
jumps up by multiple microseconds during those cycles. This behviour
seems to be related to how many satellites it sees, during times when
it has view of 5 satellites for long stretches, it seems to work fine,
but dropping down to 4 or less and it behaves crazy.

I first thought it was due to my GPS antenna (a cheap puck from ebay)
having too low signal levels, so I added an LNA4ALL[1] which uses
a MiniCircuits PSA4-5043+, to give it another 15dB of gain. It did
not really help.

What also puzzles me a bit is, that the UCCM seems to lose track of
satellites where it has clear view of them and thus strong signal.
Signal levels per satellite also vary quite a bit within a few minutes
it can go from ~35dB C/N0 to 45dB and back down... again, with clear
view of the satellite.

Does someone have an idea what could be the cause of this?
Or how I could debug this?

			Attila Kinali

[1] http://lna4all.blogspot.de/

It is upon moral qualities that a society is ultimately founded. All 
the prosperity and technological sophistication in the world is of no 
use without that foundation.
                 -- Miss Matheson, The Diamond Age, Neil Stephenson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lady_heather_uccm.png
Type: image/png
Size: 34318 bytes
Desc: not available
URL: <http://www.febo.com/pipermail/time-nuts/attachments/20171101/2530a153/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lady_heather_uccm_datalong.png
Type: image/png
Size: 10263 bytes
Desc: not available
URL: <http://www.febo.com/pipermail/time-nuts/attachments/20171101/2530a153/attachment-0001.png>

More information about the time-nuts mailing list