[time-nuts] HP 58503A question (EFC: Err)

Tom Van Baak tvb at LeapSecond.com
Fri Jan 5 08:15:13 EST 2018


Thanks for the screen shot. That means 99% of your 58503 is working; very good news.

If you look at the last line if your screen shot (attached), the self-test is failing due to EFC (Electronic Frequency Control), the voltage that pulls the quartz oscillator low or high to keep it locked at 10 MHz via GPS. The manual suggests this means the oscillator has drifted out of range, but there may be additional causes like the DAC or its bipolar power supply or the oscillator oven or oven power supply, etc.

I've not seen this error before on my 58503's, but it narrows down your problem significantly. Rather than guessing what the root cause is I'll cc time-nuts [1] to see if anyone else has seen this error, or knows what you can do about it.

There's also a useful thread at: www.eevblog.com/forum/testgear/hp-58503a-efc-error/


[1] I see your original email went to time-nuts-owner@, which ends up going privately to the couple of us who run time-nuts. But if you post to time-nuts at febo.com, then it goes out to the 1800 member list.

If you want to join see http://www.leapsecond.com/time-nuts.htm for details about the list.

If you don't want to bother joining you can read the live feed for this month at: www.febo.com/pipermail/time-nuts/2018-January/date.html

If you want to read anything every written about the 58503A, on time-nuts search google using--     site:febo.com 58503A

----- Original Message ----- 
From: Mitch Van Ochten 
To: 'Tom Van Baak' 
Sent: Thursday, January 04, 2018 7:21 PM
Subject: RE: HP 58503A question

Hi Tom,
This unit has the display also.  After applying power, the LED's on the front do a scan from left to right, the display says "HP 58503A" then the "STATUS" LED starts blinking once per second.  Thirty seconds later a message appears saying "SLFTST ERR".  The same instant the leftmost RED LED at the left rear of the circuit board comes on.
There is a GREEN LED (rightmost) in the set of six LED's, which continuously blinks once per second.  The 10 MHz output is present and the RS-232 is working.
After clearing the alarm, the "OCXO WARMUP" message appears, then a few minutes later a message saying "GPS FAILED" occurs. After waiting a while another message says "0 SAT AQUIRD". Regardless of how long you wait, it always says "0 SAT AQUIRD".
I have the unit attached to a known good active antenna.  Bought a replacement GPS receiver for it and installed it but the same error still appears. It seems as though it is not recognizing the signal from the GPS receiver, and it may be related to the self-test error.
Here is what SatStat shows:
Best regards,
From: Tom Van Baak [mailto:tvb at LeapSecond.com] 
Sent: Thursday, January 04, 2018 9:21 PM
To: mitch
Subject: Re: HP 58503A question
I opened one up here and it also has no chip in that socket. I never noticed that before. If you want me to dig further I will.
What test failed? Or what are the other symptoms? Do you get 10 MHz or 1PPS or GPS lock?
Have you tried querying it with the RS232/ SCPI interface?
----- Original Message ----- 
From: Mitch Van Ochten 
Sent: Thursday, January 04, 2018 5:02 AM
Subject: HP 58503A question
Hi John,
I recently acquired an older HP 58503A.  After power-up the "status" LED blinks for about 30 seconds, then a message comes up saying it failed self-test.  Inside it is missing a large IC (see attached photo).  Do you have one of these units?  If so, is yours also missing the IC?
Best regards,
Mitch Van Ochten

-------------- next part --------------
A non-text attachment was scrubbed...
Name: tn-mitch-58503-status.jpg
Type: image/jpeg
Size: 64948 bytes
Desc: not available
URL: <http://www.febo.com/pipermail/time-nuts/attachments/20180105/548b1877/attachment-0001.jpg>

More information about the time-nuts mailing list