[volt-nuts] 7081 won't boot

David C. Partridge david.partridge at perdrix.co.uk
Wed Sep 18 14:58:58 EDT 2013

Just to add a little to this, I found a short on the PCB between pins 5 and
12 of IC 417 (track between pads shorted with a whisker to one of the pads).
Unfortunately, fixing that has stopped the permanent "reset cycle" as $4C00
is now going to 0V correctly, but the board still isn't finishing the boot
sequence :(

David Partridge 
-----Original Message-----
From: volt-nuts-bounces at febo.com [mailto:volt-nuts-bounces at febo.com] On
Behalf Of David C. Partridge
Sent: 18 September 2013 10:09
To: 'Discussion of precise voltage measurement'
Subject: [volt-nuts] 7081 won't boot

Lst Friday I tried to power up one of my 7081s to do some work.

Problem was it wouldn't boot up.  The problem looked to be a fault on the
earthy processor board (rubbish on the display scrolling off to the left and
flashing front panel LEDS).  Swapping the board from another meter did
indeed confirm the problem was on the earthy processor or "Brain" board.

I soon established that there was no good $4C00 select signal going to the
logic board with the result that the processor was continually being reset.

Remembering my other 7081 with the same symptoms was bad ROMs, and seeing
that the only ROM select signals were going to $E000 which is the boot ROM
(IC412) and to $6000 which is IC430, I used my two remaining 2764s to
re-burn and replace those.  I also did a full verify and check sum check on
all the ROMS. No luck.

My next thought was that it could be a problem with the 74LS138 decoders and
replaced them (with much cussing) with new ones in sockets but that didn't
help either.

I then put back the two original ROMs and one by one did a swap test on the
others (erasing and burning as I went), again no luck.

The problem could still be bad ROMs of course as these are all old parts.

I couldn't swap ROM sets with the other meter as that one uses 2564s.

My only other observation is that the $4000 signal on pin 13 of IC416 is
somewhat strange in that it dips from 5V to about 2.5V for a short time and
then pops back up rather than being a solid 5V to 0V signal - almost as if
it were a timing artefact:  

 --- --- instead of ---  ---

I thought this was a dodgy LS138, but swapping LS138s did no good.

I also tried swapping the processor and DMA chips between the boards, but
that changed nothing.

I feel like I've been banging my head on a brick wall for the last five
days, as I'm no further forward at all.

So I think it is time to ask for suggestions ...

David Partridge 

volt-nuts mailing list -- volt-nuts at febo.com To unsubscribe, go to
and follow the instructions there.

More information about the volt-nuts mailing list