[time-nuts] Synergy-GPS SSR-6tru problems

Dennis Ferguson dennis.c.ferguson at gmail.com
Wed Jul 16 00:46:19 EDT 2014

On 15 Jul, 2014, at 16:32 , Bob Stewart <bob at evoria.net> wrote:
> I do not know what the problem is.  The UT+ works (with the appropriate software).  The SSR-6tru is deaf using all the software I have available to me.  I am at my wits end, and I have nothing else that I can think of to try.

I've got several of these boards and they've worked okay for me
without doing anything special.  I have not tried the software
you are using, however, nor do I use the adapter you mention
(does that adapt the connector on the SSR-6tru to a connector
that fits your UT+ board?).  I made a connector to talk
to mine directly from a 3 volt serial port in a BBB SOIC.

Since you can see the NMEA sentences the transmit side of the
serial port from the LEA-6T is clearly working and you have
the baud rate right, but your symptoms suggest the module doesn't
hear you.  Have you tried looking at the basic connection, i.e.
that the serial port receive pin on the module wiggles at the
right voltage and polarity when the software tries to send
stuff (maybe there are two ways to plug in the adapter, only
one of which works)?  If that looks okay then the only other
guess I can think of is that the software is trying to talk
to the board with u-Blox binary messages but that protocol has
been turned off for input on the port (the PUBX,41 NMEA sentence
can turn it on and off), but that seems unlikely since, no
matter how I reconfigure mine, a power-on reset always sees
the serial port come up willing to receive either protocol.

Dennis Ferguson

More information about the time-nuts mailing list