[time-nuts] Synergy-GPS SSR-6tru problems

Bob Stewart bob at evoria.net
Wed Jul 16 14:54:04 EDT 2014


I fooled around with PUBX 41, and can't get the board to respond.  I 
think that with the original board, I *once* got some PUBX messages, but at this point I am only seeing NMEA broadcasts.  That once may have 
been when I was using a serial port instead of the USB I'm using right 
now.  This evening I will get in with the scope and do come comparisons 
on the 10-pin connector to see if there are differences between then the UT+ 
is plugged in and the SSR-6tru mounted on the adapter card.  I have an 
ftdi adapter that I may put on as well if nothing else gives any 

I don't have the ability to deal with those .05" spaced pins on the GPS 
board's connector, or to supply the 3V power.  But, if needs be, I can 
get a connector, put in a 3V regulator, and give that a try.  Come to 
think of it: one of my little USB to TTL adapter boards can supply 3V.  
Maybe I can use some mini-clips to jumper directly to the .05" pins on the GPS board, let the USB adapter 
supply the 3V, and give that a try.  I'm a bit leery of going that 
route, though.  If I get pins mixed up and blow the board I've wasted 
all this time for nothing.


 From: Dennis Ferguson <dennis.c.ferguson at gmail.com>
To: Discussion of precise time and frequency measurement <time-nuts at febo.com> 
Cc: Bob Stewart <bob at evoria.net> 
Sent: Tuesday, July 15, 2014 11:46 PM
Subject: Re: [time-nuts] Synergy-GPS SSR-6tru problems

On 15 Jul, 2014, at 16:32 , Bob Stewart <bob at evoria.net> wrote:
> I do not know what the problem is.  The UT+ works (with the appropriate software).  The SSR-6tru is deaf using all the software I have available to me.  I am at my wits end, and I have nothing else that I can think of to try.

I've got several of these boards and they've worked okay for me
without doing anything special.  I have not tried the software
you are using, however, nor do I use the adapter you mention
(does that adapt the connector on the SSR-6tru to a connector
that fits your UT+ board?).  I made a connector to talk
to mine directly from a 3 volt serial port in a BBB SOIC.

Since you can see the NMEA sentences the transmit side of the
serial port from the LEA-6T is clearly working and you have
the baud rate right, but your symptoms suggest the module doesn't
hear you.  Have you tried looking at the basic connection, i.e.
that the serial port receive pin on the module wiggles at the
right voltage and polarity when the software tries to send
stuff (maybe there are two ways to plug in the adapter, only
one of which works)?  If that looks okay then the only other
guess I can think of is that the software is trying to talk
to the board with u-Blox binary messages but that protocol has
been turned off for input on the port (the PUBX,41 NMEA sentence
can turn it on and off), but that seems unlikely since, no
matter how I reconfigure mine, a power-on reset always sees
the serial port come up willing to receive either protocol.

Dennis Ferguson

More information about the time-nuts mailing list