[time-nuts] Ashtech Z-12 firmware?

Magnus Danielson magnus at rubidium.dyndns.org
Sat Aug 27 11:39:35 EDT 2016


On 08/27/2016 01:34 AM, Gregory Maxwell wrote:
> I recently picked up a couple non-functional Ashtech Z-12 receivers
> with the external frequency input (these appear to PLL an internal
> TCXO; I understand there are other models where they replace the TCXO
> completely).
> I was hoping to use them both better data sources for common view time
> transfer with better performance than the GPS L1/CA  that I've been
> using; as well as using them for ground truth data for a SDR
> semi-codeless CRPA receiver I'm slowly building.
> These units were hanging at startup at "Downloading channel". I
> determined that they would work a single time if the memory were
> cleared (by holding an arrow, right for external up for internal,
> during start). Because the internal 3.6v primary cell batteries were
> reading about 40mv I took a guess that the low battery was causing
> memory corruption across restarts.
> New batteries and a bit of soldering later, and they are working
> reliably across restarts, locking sats on L1/L2, talking on RS232,
> etc. (hurrah).  Hopefully this message in the archives is useful if
> someone else encounters similar symptoms.

Thanks for that. One of my Z12s have that issue, so now I know it is 
battery related. Many thanks for that!

> Before I go further I was wondering if anyone knew of a source for
> firmware for these old units?  One of mine is marked "Z-12 700751-6
> (b)", unfortunately it seems ashtech has been sold many times, and the
> old web/ftp sites have been scattered to the wind.

Indeed. It used to be available, now one has to look for it.
I'll send you what I could locate quickly.


More information about the time-nuts mailing list