[time-nuts] Newbie With a Z3801 Problem

Dave Hallidy k2dh1 at frontier.com
Fri Nov 4 17:48:09 EDT 2016


Hi all-

Dave K2DH here.  I'm new to the group as of today.  I have an old HP Z3801A
that I've had for years and which has been packed away for several years.
It worked when I put it away, but now, although it seems to come up
correctly, I have no serial comms with it.

I'm looking for a little help here, maybe a new suggestion or two.  I'll
tell you what I've tried.

 

When I used it before, I used it with an old Fujitsu laptop running (I
think) Windows 98SE.  I had modified the Z3801's port for RS-232 and it
worked fine for several years.

 

When I got it out the other day, I used the same cable that I had made for
it before (basically a null modem, crossing RXD and TXD).  I loaded SatStat
and tried to run it, but it wouldn't communicate with the receiver.  The
current computer is a Win 7 laptop with a Prolific USB to Serial converter,
but I also tried several XP computers, with the same result.

 

I've confirmed that I'm using the correct com port and I've gotten to the
point of even putting a scope on the RS-232 output and input on the
receiver.  I see requests to connect coming into the Z3801, but no response
of any kind- the 232 line just stays low.  I backed up to the serial driver
chip on the 3801's main board (an LT1180 RS-232 driver/receiver) and the
receiver is passing the request on to the processor, but the driver is not
changing state.  So apparently, the processor on the board doesn't recognize
the command SatStat is sending to it.

 

I've tried the recommended baud rate of 19200,7, O,1 but also just about all
other combinations- thinking maybe the old Fujitsu wasn't capable of 19200
and I might have changed the baud rate.  But all to no avail, and frankly, I
wonder if the 19200,7O,1 configuration isn't hard-coded into the Z3801 and
can't be changed.

 

I've made sure my com port setting on the computers' device managers
correspond to the settings I'm using in SatStat, so the setting should allow
the two to talk to each other.

 

I've had it on for numerous long periods and it hasn't achieved GPS lock,
but I assume that's because it's not in survey mode and I was in a different
location last time I used it.  It goes into holdover after a period of time.

 

Has anyone else experienced this and if so, were you able to overcome it
successfully?  RS-422 isn't really an option and as I said, it used to work
fine via RS-232.

 

Thanks in advance for any assistance- I've become quite interested in
precision time and would like to get this thing running again.

 

73

Dave K2DH



More information about the time-nuts mailing list