[time-nuts] GPScon running on Raspberry Pi 3b

timenut at metachaos.net timenut at metachaos.net
Mon Jun 26 12:49:58 EDT 2017


That is exactly the right processing order. However, it shouldn't actually try
the USB port until after that processing is done. In other words, if the
configuration file has -1u and the command line has -4u, it should never try
USB0 because that was overridden on the command line. It should try USB3 and
succeed or fail based on that.

Did you get what you needed from the build this morning?

Michael Lee Finney

> Heather's configuration priority is to process:  hard coded defaults,  then
> the config file,  and finally the command line options.  This lets you set
> your preferred settings in the config file and then override your config file options from the command line.

> --------------------

>> When I ran it with ./heather -4u, it first told me that it was unable to open /dev/ttyUSB0 and
> then told me it was unable to open /dev/ttyUSB3. This is probably due to the
> configuration file containing "-1u", but if that option is given on the
> command line then the configuration file value should be ignored - or at the
> least it should be tried after the command line option.
> _______________________________________________
> time-nuts mailing list -- time-nuts at febo.com
> To unsubscribe, go to https://www.febo.com/cgi-bin/mailman/listinfo/time-nuts
> and follow the instructions there.

Best regards,
 Timenut                            mailto:timenut at metachaos.net

More information about the time-nuts mailing list