[time-nuts] GPScon running on Raspberry Pi 3b

Chris Albertson albertson.chris at gmail.com
Mon Jun 26 14:51:48 EDT 2017

On Sun, Jun 25, 2017 at 3:04 PM, Mark Sims <holrum at hotmail.com> wrote:

> Heather's configuration priority is to process:  hard coded defaults,
> then the config file,  and finally the command line options.  This lets you
> set your preferred settings in the config file and then override your
> config file options from the command line.

If that is the desired behavior and I think it is reasonable and what most
people would expect,  then the correct implementation of that behavior is
to NOT ACT on any config setting until the command line options are read.
Or in general never act on an instruction that might be overridden

So the bug reported below seems to be a bug.

> --------------------
> > When I ran it with ./heather -4u, it first told me that it was unable to
> open /dev/ttyUSB0 and
> then told me it was unable to open /dev/ttyUSB3. This is probably due to
> the
> configuration file containing "-1u", but if that option is given on the
> command line then the configuration file value should be ignored - or at
> the
> least it should be tried after the command line option.
> _______________________________________________
> time-nuts mailing list -- time-nuts at febo.com
> To unsubscribe, go to https://www.febo.com/cgi-bin/
> mailman/listinfo/time-nuts
> and follow the instructions there.


Chris Albertson
Redondo Beach, California

More information about the time-nuts mailing list