[volt-nuts] Datron 1281 NVRAM woes

Todd Micallef tmicallef at gmail.com
Thu Apr 14 22:50:28 EDT 2016

I tested both 1281 since they are running different FW

1281 #1 FW 3.02
All four tests produced the same error when the cable was disconnected at
the DCV, AC assy, Ohms assy, and Current assy.

9005 Serial Interface Fault 00150C  03

1281 #2 FW 3.11
Different error than above but it is the almost the same on all four tests.

9005.9 Ponntru/compl  00173A

The DCV was slightly different at:

9005.9 Pon tru/compl  00173A.

One interesting note is that on one meter the readout can give repeated
characters if upside-down. But once it is right side up, the display is
fine. The only thing that comes to mind is the EPROMs are failing. I plan
on upgrading both soon so I can try it again.


On Thu, Apr 14, 2016 at 5:21 PM, Todd Micallef <tmicallef at gmail.com> wrote:

> I will get it this evening. Hope to be finished with work within the next
> couple of hours.
> On Thursday, April 14, 2016, Bert Kachler <bkachler at hotmail.com> wrote:
>> Hi Todd and ??,
>> thanks for your answers!
>> I think it is a good suggestion to
>> try to see first whether the Eproms are intact. Firmware is
>> Version 3.11 and I have ordered new EProms to put
>> a copy of the 3.11 firmware on them, the one
>> from https://xdevs.com/fix/d1281/#manual .
>> I will fire up my programmer the moment they arrive.
>> What makes me ponder is that there were suddenly apparently
>> two errors after a couple of month's inactivity.
>> If two errors appear out of the blue more or less at the same
>> time, IMHO it is likely that there is a common reason.
>> Hence first the Eprom test. Then perhaps the voltages,
>> I still need to figure out what they are supposed to be
>> at the test points of the undocumented digital board.
>> (I am not sure
>> whether the NVRAM error came exactly at the same first turn-on
>> as the "9005.7 No Rtx    001B42" error, because it
>> flashes only briefly and I might have overlooked it at first.
>> I only noticed it after a few subsequent turn ons, when I tried
>> to made a picture to the "9005.7 No Rtx    001B42" error display.)
>> Assuming that nothing of the above works, which is likely,
>> then there is still the main question of what the "secondary" part of the
>> NVRAM is supposed to be. If it happens just a secondary backup copy
>> of the whoke memory, then there might be a chance to
>> correct it (like for Solartron 7081 which does keep 2 copies of the data).
>> I keep you posted. Thanks for your help.
>> Cheers,
>> Bert
>> _______________________________________________
>> volt-nuts mailing list -- volt-nuts at febo.com
>> To unsubscribe, go to
>> https://www.febo.com/cgi-bin/mailman/listinfo/volt-nuts
>> and follow the instructions there.

More information about the volt-nuts mailing list